WordPress Requirements & Checklist

Last updated

Requirements for Getting Started

Make sure Blossom Travel Pro is compatible with your WordPress version.

Blossom Travel Pro will work with 4.7 and above versions of WordPress.

However, for the best experience, added features, and updated security patches, we recommend you to update your WordPress to the latest version.

If you haven’t downloaded WordPress already, you can download it from the WordPress repository via https://wordpress.org/download/.

Checklist for Getting Started:

  • Check WordPress Version and Update it.
  • Install and Activate Blossom Travel Pro WordPress theme.
  • Install Recommended Plugins. Some functionality of the theme might not work if you do not install the recommended plugins.

Please follow the below steps to check and update the WordPress version if available:

  • Log in to the WordPress admin panel
  • Go to Dashboard >Updates.

WordPress-Update

Please update the WordPress version if there is an update available. It is always recommended to use the latest version of WordPress for extended features and better security of your website.

 

Still stuck? How can we help?
Was this article helpful for you?